Как правильно настроить virtual reassembly



Сообщение от unpinget on 04-Сен-06, 16:39

Подскажите, как настроить нат а cisco 2801

у меня такая конфигурация


interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.10.10.1 255.255.255.0
no ip proxy-arp
ip nat inside
ip virtual-reassembly
no snmp trap link-status
no cdp enable
!
interface FastEthernet0/0.12
encapsulation dot1Q 12
ip address 65.66.67.18 255.255.255.240
no ip proxy-arp
ip nat outside
ip virtual-reassembly
no snmp trap link-status
no cdp enable
!
access-list 50 permit 10.10.10.0 0.0.0.255
ip nat inside source list 50 interface FastEthernet0/0.12 overload

пробую пингануть с компьютера с ip 10.10.10.5:
до 10.10.10.1 все ок
до 65.66.67.20 Заданный узел недоступен

п.с. извините что отнимаю время :)

Сообщение от slw (??) on 04-Сен-06, 16:44

>Подскажите, как настроить нат а cisco 2801
>
>у меня такая конфигурация
>
>!
>interface FastEthernet0/0.10
> encapsulation dot1Q 10
> ip address 10.10.10.1 255.255.255.0
> no ip proxy-arp
> ip nat inside
> ip virtual-reassembly
> no snmp trap link-status
> no cdp enable
>!
>interface FastEthernet0/0.12
> encapsulation dot1Q 12
> ip address 65.66.67.18 255.255.255.240
> no ip proxy-arp
> ip nat outside
> ip virtual-reassembly
> no snmp trap link-status
> no cdp enable
>!
>access-list 50 permit 10.10.10.0 0.0.0.255
>ip nat inside source list 50 interface FastEthernet0/0.12 overload
>
>пробую пингануть с компьютера с ip 10.10.10.5:
> до 10.10.10.1 все ок
> до 65.66.67.20 Заданный узел недоступен
>
>заранее благодарю!
>
>п.с. извините что отнимаю время :)

А с циски 65.66.67.20 пингуется?

2. "как правильно настроить нат?"

Сообщение от sh_ (??) on 04-Сен-06, 16:44

sh ip ro покажите
sh ip nat tran

3. "как правильно настроить нат?"

Сообщение от unpinget on 04-Сен-06, 16:56

cs#>show ip route

Gateway of last resort is 65.66.67.17 to network 0.0.0.0

10.0.0.0/24 is subnetted, 2 subnets
C 10.10.10.0 is directly connected, FastEthernet0/0.10
65.66.67.0/28 is subnetted, 1 subnets
C 65.66.67.16 is directly connected, FastEthernet0/0.12
S* 0.0.0.0/0 [1/0] via 65.66.67.17

cs#>show ip nat tran
<пусто>

4. "как правильно настроить нат?"

Сообщение от unpinget on 04-Сен-06, 17:18

оказывается на компьютере с windows поему-то небыл прописан default gw :(

извините что потревожил (

Сisco Сatalyst

[править ] Объединение в кластер 2960

Cisco 2960 не поддерживает кластеризацию, для этого необходим, как минимум 3750. Но создать одну логическую группу, как минимум возможно Эту особенность позволяет получить доступ к устройству "из коробки". без доступа к консоли. Для работы требуется включенный CDB

Для поиска списка устройств можно использовать команду show cluster candidates

[править ] Зеркалирование портов

[править ] Настройка vlan

[править ] Подавление широковещательных пакетов

[править ] Конфигурирование интерфейса для операций третьего уровня

Что бы настроить порт в качестве порта третьего уровня необходимо выполнить команду no switchport. В результате на этом порту будут отключены функции 2 уровня и будут включены функции третьего.
Пример:

[править ] Предотвращение атак, связанных с фрагментацией пакетов

Атаки, основанные на фрагментации пакетов приводят к переполнению буфера. Основаны они на том, что на маршрутизатор/коммутатор приходит лавина незаконченных фрагментированных пакетов Для их избежания этой ситуации используется команда ip virtual-reassembly [options]

Данная возможность включается автоматически на интерфейсах (при возможности поддержки этой функции) при включении на интерфейсе Nat, firewall или IDS

Для просмотра используется команда

[править ] Power over Ethernet

Для включения\выключения подачи питания через Ethernet используется команда: power inline auto|never|static
Пример:

[править ] Настойка UDP broadcast

Роутеры умеют принимать и генерировать broadcast трафик, но они не умеют перенаправлять его. Это может вызвать проблемы например с DHCP сервером. Компьютер может пытаться найти с помощью broadcast пакетов DHCP сервер, но эти пакеты никогда не попадут на сервер.

Для избежания этой ситуации используется команда ip helper-address Эта команда должна быть настроена на интерфейсе, который будет получать brodcast пакеты.

Эта команда умеет транслировать 8 broadcast сервисов:

  • TIME, port 37
  • TACACS, port 49
  • DNS, port 53
  • BOOTP/DHCP Server, port 67
  • BOOTP/DHCP Client, port 68
  • TFTP. port 69
  • NetBIOS name service, port 137
  • NetBIOS datagram service, port 138

[править ] См. также

Сообщение от fantom (ok) on 08-Июл-11, 16:22

>&#091;оверквотинг удален&#093;
> ip address 172.16.1.254 255.255.255.0
> ip mtu 1492
> ip nat inside
> ip virtual-reassembly
> autodetect encapsulation ppp
> ppp authentication chap callin
>.
>


> Необходимо, необходимо поднять interface Virtual-Template2, при доключении к которому
> пользователи получали адреса по dhcp. Как это правильно сделать?

ip local pool - создаем пул адресов
на
interface Virtual-Template2
peer default ip address pool ИМЯВАШЕГОПУЛА

2. "Как правильно настроить interface Virtual-Template2?"

Сообщение от tetst (ok) on 08-Июл-11, 16:34

> ip local pool - создаем пул адресов
> на
> interface Virtual-Template2
> peer default ip address pool ИМЯВАШЕГОПУЛА

виндовому клиенту выдается ошибка 718:сервер не назначил адрес.
а в логах циски такое

может на радиус-сервере есть нужно что-изменить или наоборот добавить?

3. "Как правильно настроить interface Virtual-Template2?"

Сообщение от fantom (ok) on 12-Июл-11, 11:49

>&#091;оверквотинг удален&#093;
>> interface Virtual-Template2
>> peer default ip address pool ИМЯВАШЕГОПУЛА
> виндовому клиенту выдается ошибка 718:сервер не назначил адрес.
> а в логах циски такое
>
> может на радиус-сервере есть нужно что-изменить или наоборот добавить?

Пул создали?
Ссылку на него в Virtual-Template1 добавили?

4. "Как правильно настроить interface Virtual-Template2?"

Сообщение от tetst (ok) on 12-Июл-11, 13:20

> Пул создали?
> Ссылку на него в Virtual-Template1 добавили?

наверное имели ввиду Virtual-Template2? Сделал даже вот так, но результат тот же.

5. "Как правильно настроить interface Virtual-Template2?"

Сообщение от fantom (ok) on 12-Июл-11, 14:28

>&#091;оверквотинг удален&#093;
> interface Virtual-Template2
> description dhcp_pptp
> ip unnumbered Ethernet0/0
> ip mtu 1492
> ip nat inside
> ip virtual-reassembly
> peer default ip address dhcp-pool TEST_DHCP
> ppp authentication chap
>.
>

ip local pool TEST 172.16.3.1 172.16.3.254

interface Virtual-Template2
peer default ip address pool TEST

6. "Как правильно настроить interface Virtual-Template2?"

Сообщение от tetst (ok) on 12-Июл-11, 21:51

> ip local pool TEST 172.16.3.1 172.16.3.254
> interface Virtual-Template2
> peer default ip address pool TEST

и такой вариант пробовал, результат тот же, соединение происходит на Virtual-Template1

7. "Как правильно настроить interface Virtual-Template2?"

Сообщение от fantom (ok) on 13-Июл-11, 09:54

>> ip local pool TEST 172.16.3.1 172.16.3.254
>> interface Virtual-Template2
>> peer default ip address pool TEST
> и такой вариант пробовал, результат тот же, соединение происходит на Virtual-Template1

Покажите весь конфиг, ато у вас то Virtual-Template1 то
Virtual-Template2 - определитесь енаконец что там у вас накручено - наверчено.

Источники: http://opennet.ru/openforum/vsluhforumID6/11424.html?n=slw, http://xgu.ru/wiki/%D0%A1isco_%D0%A1atalyst, http://www.opennet.ru/openforum/vsluhforumID6/22854.html




Комментариев пока нет!

Поделитесь своим мнением